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Section I: Introduction 
TOPSpro is a software that: 

• Is developed and updated by CASAS; 
• Scans and automatically scores student answer sheets of pre-post tests; 
• Allows for scanned pre-post test data to be imported into CARS; and 
• Provides numerous individual and class level reports for aligning assessment to 

instruction. 

Statewide Policies Relative to TOPSpro use 
• The Bureau encourages the use of TOPSpro by Connecticut programs so as to 

minimize the data entry burden and obtain assessment reports that inform instruction. 
• For now, the Bureau provides the TOPSpro software and the TOPSpro Test Record 

scannable answer sheet to Connecticut TOPSpro users at no-cost. To request copies 
of the Test Record, please email Gina Hoag at gina.hoag@ct.gov. 

• The use of TOPSpro for appraisal testing is currently not supported. 
• Technical questions regarding TOPSpro should be directed to CASAS HelpDesk at 

800-255-1036. 

Install and Prepare TOPSpro:  
Backup Your Data (Existing Users Only) 
Before proceeding with the installation please back up your data folder. If you've used the 
default directory, then C:\Program Files\Casas\Visual TOPSpro - Production\Data 
contains all the records that you have entered into TOPSpro. It is highly recommended 
that you copy your data folder to a safe place now. 

 
How to install TOPSpro 

• If your computer is on a network ask your network administrator to install this 
software. On many systems it is necessary to have administrative rights in order to 
install software. 

• Close all applications and turn off virus protection software. If you're concerned 
about the possibilities of viruses coming from TOPSpro then scan the TOPSpro 
CD for viruses before installing. 

• Insert the TOPSpro CD into the CD-ROM drive. Wait 30 seconds. If the program 
does not load automatically, then go to the Start button in the lower left hand 
corner of Windows and choose Run. Type D:\setup.exe and hit enter (assuming D 
is the letter assigned to your CD-ROM drive). 

• When the Welcome window appears, choose [Next] to continue installation. 
• Choose [Yes] to accept the license agreement. 
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• Type your Name and Company/Agency and choose [Next]. 
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• Important: To install over an existing installation, the destination folder needs to 
be exactly where the existing TOPSpro resides now. The default destination is 
C:\Program Files\Casas\Visual TOPSpro - Production. If you or your Systems 
Administrator put TOPSpro somewhere other than the default, then click the 
Browse button and navigate to your existing TOPSpro installation. 

• Choose [Next] for Stand-alone or Network Server. 
• Choose [Next] for Program folder: CASAS. 
• If you are prompted to overwrite a read-only file respond with [Yes] 
• Choose [Finish] to complete the installation. 
 
If you are installing to a network you should follow the general instructions above, 
but be sure you are doing this on your server. Afterward, locate the "Installation and 
Setup" folder inside the "Visual TOPSpro - Production\Help" folder. The Installation 
and Setup document will include more information on setting up your workstations 
 
Launch TOPSpro 

• From the Start button in Windows, choose "Visual TOPSpro - Production". 
This will launch the application you just installed. 

• Type "LOCAL" for Username and click [OK]. 
 

IMPORTANT: For the TOPSpro-CARS bridge to work, both the agency and site 
number in TOPSpro must be filled in with your three-digit town/agency code 
specified in CARS. Select File > Open > Agency Lister/Town Lister, hit F5 and 
ensure that this data is accurately entered. 
 
Note: If you are asked for a license number and you are not a new user, then the 
path name specified during installation was incorrect. If you are a new user, 
contact CASAS to obtain a license number. 
 

Turn Off All Required Fields in TOPSpro 
TOPSpro uses Required Fields to help you identify missing data. Since this function 
is already performed in CARS and since not all of the data in CARS is imported to 
TOPSpro it is probably more convenient to turn off Required Fields in TOPSpro. To 
do this:  
• Launch TOPSpro. 
• Choose Tools > Options > Required Fields 
• Click the Clear All button 
• Click OK. 

 
You only need to do this once, and it is best to do it before the first time you import 
records. If you’ve already imported records, then choose Tools-Database-Revalidate 
Database and run the wizard after you followed the three steps above. 
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Purchase and Set up Scanner 
TOPSpro uses a pencil-read, 48-channel optical mark reader. Only the two companies 
below manufacture the type of scanners that are compatible with TOPSpro:  
 
Scantron ScanMark 2000 and 8000 series (48 channel)  
1361 Valencia Ave.  
Tustin, CA 92780-6463 
(800) 445-3141, (714) 247-0010 Fax 
www.scantron.com  
(Uses configuration sheets to configure) 
 
NCS Pearson OpScan 3, 4, 5, 6, 7 
11000 Prairie Lakes Drive 
Eden Prairie, Minnesota 55344-3857  
(800) 338-5544, www.ncspearson.com  
(Uses configuration sheets to configure) 

 
Note: Photo scanners, such as those manufactured by Epson, HP or Visioneer, are 
NOT compatible with TOPSpro. 
 
To set up the scanner in TOPSpro, select Tools > Options > Scanning and customize 
the settings to work with the scanner at your program. 
 

Section II: The CARS-TOPSpro Data Exchange Process 
The process of exchanging data with TOPSpro involves exporting student and course 
section information from CARS to TOPSpro, creating customized answer sheets, 
scanning the answer sheets and automatically scoring the tests in TOPSpro, and then 
importing the test results from TOPSpro into CARS. This process is cumulative and can 
be repeated several times as new students come into the program. 

1. Enter Data Early 
• Enter Students (Demographics, Appraisal Scores, Entry Status and Reasons for 

Enrollment) 
• Enroll students in classes. 

 

2. Select TOPS Exchange from the CARS Menu 
 

From the CARS menu select “Misc” > 
“TOPS Exchange”. 
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3. Export Student Demographics from 
CARS 

 
Click “Export Student Data To TOPS.” 
 
Then click “Download Export Student Data To 
TOPS (SDF And Logs).” Unzip the file as prompted 
and save the SDF file to a desired location. TOPS 
requires that the import file have an SDF Extension. 
 
 

4. Export Course and Section Data from 
CARS 

 
Click “Export Class Data To TOPS.” 
 
Then click “Download Export Class Data To TOPS 
(SDF And Logs).” Unzip the file as prompted and 
save the SDF file to a desired location. TOPS requires 
that the import file have an SDF Extension. 

5. Import CARS Student Data into 
TOPSpro 
• Launch TOPSpro 
• Select Wizards > Import/Export 
• Select “Import data from another system into this installation” 

e and Demographics from a 3rd party system” 

 folder with magnifying glass on it 

DF file containing CARS students created in Step 3 

 Click Finish 

 see the list of students 
imported. Click Cancel to perform any other function. 

• Click Next 
• Select “Nam
• Click Next 
• Select “System Data Format (SDF)” 
• Click on the icon that looks like a
• Change directories as necessary 
• Select the S
• Click OK 
• Click Next 
•

 
A pop-up box should appear. You may click Preview to
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ctions into TOPSpro: 

rds > Import/Export 
is installation” 

 system” 

)” 

ectories as necessary  
F file containing CARS course-sections created in Step 4 

 Click Next 

A pop-up box should appear. You may click Preview to see the list of course-sections 
imported. Click Cancel to perform any other function. 

 

7. 

) 

s 

 laser printer include the TOPS ID#, the Class Number assigned by TOPS for CARS 

 the Section, 
nd the student(s) or click Select All Students, and then click Print Selected Forms. Note:

6. Import CARS Courses and Se
• Launch TOPSpro 
• Select Wiza
• Select “Import data from another system into th
• Click Next 
• Select “Class records from a 3rd party
• Click Next 
• Select “System Data Format (SDF
• Click on the icon that looks like a folder with magnifying glass on it. 
• Change dir
• Select the SD
• Click OK 
•
• Click Finish 
 

Pre-Printing Answer 
Sheets (see TOPS 
test record attached
This step provides 
programs the option of 
pre-bubbling select field
in the TOPS Test Record 
(student answer sheet) 
prior to the student taking 
the test. Sample fields that 
can be bubbled in through 
a
Course-sections, the test form number and test date. 
 
This pre-bubbling function in available through CARS; select Misc > TOPS Print. Click 
on the Print Test Form to get a bubbled print out of the data columns on the TOPS Test 
Record. Utilize this to set the horizontal and vertical offsets for your printer. To print the 
customized TOPS Test Record for one or more students, select the Course,
a  

 
The TOPS Test Record will not indicate the CARS Course-section name. 
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TO  u
• BER but not the test 

 with regular attendance and pre-bubble the test 

 jams 
and because the answer sheets need to be in the same order as in CARS. 

In T P rds.  
ted 

f necessary by clicking on the ∑ icon. 
• Save the record. 

9. Export Test Data from TOPSpro 
 

To export test data from TOPSpro, first launch T
 

•  Database > 

m’s data for 

m”  

t (only Test 

at must be SDF 
• Click Next 

 
• nt 

generally 
n be changed 

• Click Next 

PS sers utilize different strategies to minimize the wastage of these forms: 
Pre-bubble select fields like TOPS ID and CLASS NUM
form and test date since those are prone to change; 

• Have teachers indicate students
record only for those students; 

• Not pre-bubble post-tests because the over-usage of paper results in paper

8. Repair the Scanned Data 
O Spro, select Tools > Batch Repair > Test and Appraisal reco
• Select the student for whom the error needs to be correc
• Rescore the test i

OPSpro, then 

Choose Tools >
Import/Export 

• Select “Export this syste
use on another system” 

• Select “Export for 3rd party syste
• Deselect the Entry, Student and 

Class tables to expor
should be checked) 

• Export Form

 
 

Date ranges are generally the curre
program year, but can be changed 

• Agency, Site, Class, etc. is 
“All”, but ca
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• ave data on disk or 

 

ated for 
ARS data 

• Click Finish 

 

10. Import Test Data into CARS 
 

To import test data from TOPSpro, first launch CARS, then 
 

owse and select the file that you exported from TOPS and press the OPEN 

le, if the date is 
_TEST6050.SDF) 

 Then click the “Import Test Data From TOPS

Click on “S
3.5” disk” 

• Click on the Hard Drive icon
• Navigate to the “Exchange” 

folder on your C drive or the 
folder you have design
TOPSpro-C
exchange. 

• Click Save 
• Click Next 

 
 
 
 

• Select Misc > TOPS Exchange 
• Click Br

button. 
(This file will be named according to the date you exported, for examp
10-10-2003 then the file will be called: x20031010

• ” 

 as the extension. Double 
lick on it to launch WordPad then print the log for reference.  

 
 

 
If you receive an error message while importing check the log file in designated folder. It 
will have the same filename as referenced above, but with LOG
c



CARS-TOPSpro Data Exchange Overview 
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CARS 

SDF File of 
Students 

SDF File of 
Classes 

 
 
2. Export Student and Class Data from 

CARS through Misc > TOPS Exchange 

TOPS 

 
3. Launch 

TOPS & 
Import 
Student and 
Class Data 

1. Pre-print answer sheets 
(optional). Students take test. 

Scanner 
4. Answer sheets 

scanned into and 
automatically 
scored by TOPS. 

SDF File of 
Test Data 5. Export Test Data from TOPS into SDF file  

6. Launch 
CARS 
and 
Import 
Test Data 
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